Configuration Error - Target Framework 2.0 instead of 4.x

All Nodinite Web Applications uses .NET 4.5 or later, hence Windows 2008 R2 customers must update the .NET Framework to 4.5. This may be a problem if BizTalk Server is installed on the same server. Web Client
Web API
LogAPI

The Problem

Invalid configuration of the IIS Application Pools will render Nodinite not operational.

During installation of Nodinite Update and the creation of new application pools for Nodinite in IIS, the default target framework on mainly Windows 2008 R2 and earlier Windows version will set .NET 2.0 as default instead of 4.x and the Web Applications will therefore not work/run.

HTTP Runtime

Solution

Make sure the Application Pools for Nodinite related Web Applications run with .NET 4.x framework

How do I change the .NET version in IIS for selected Application Pools?

  • Click Start, click Run, type inetmgr and then click OK to open Internet Information Services (IIS) Manager
  • In the tree, click to expand Web Server and then click Application Pools
  • Look for the appropriate Application Pool, for example Nodinite Update
  • Right click on Nodinite Update and click Basic Settings to display the Edit Application Pool dialog box
  • Change the .NET CLR version from .NET CLR Version v2.0.5727 to .NET CLR Version v4.0.30319
  • Click OK
  • Reload page in browser

IIS Settings


Next Step

Install Nodinite

Web Client
Web API
LogAPI